So I tried actually building this, and CONFIG_INFINIBAND_IPATH=y +
CONFIG_INFINIBAND_QIB=y ends up with:

    drivers/infiniband/hw/qib/built-in.o: In function `signal_ib_event':
    drivers/infiniband/hw/qib/qib_intr.c:72: multiple definition of 
`signal_ib_event'
    
drivers/infiniband/hw/ipath/built-in.o:drivers/infiniband/hw/ipath/ipath_intr.c:248:
 first defined here
    drivers/infiniband/hw/qib/built-in.o: In function `teardown_sdma':
    drivers/infiniband/hw/qib/qib_sdma.c:475: multiple definition of 
`teardown_sdma'
    
drivers/infiniband/hw/ipath/built-in.o:drivers/infiniband/hw/ipath/ipath_sdma.c:508:
 first defined here

etc.

I think it's a good idea to prefix any symbols with non-static scope
with the driver name, so these should become qib_xxx to avoid conflicts
(and fixing the too-generic names in ipath wouldn't hurt either).

 - R.
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to