> > Rather than having IB_PMA_SEL_* and IB_PMA_SELX_*, we could follow
> what's done in ib_sa.h:
> > IB_PM_<structure>_<field>
> 
> I would need some guidance here...  maybe you can elaborate a little
> further with the V1 posting which will follow soon

Here's part of a comment from ib_sa.h:

 * Structures for SA records are named "struct ib_sa_xxx_rec."
 * For a record with structure ib_sa_xxx_rec, the naming convention
 * for the component mask value for field yyy is IB_SA_XXX_REC_YYY (we
 * never use different abbreviations or otherwise change the spelling
 * of xxx/yyy between ib_sa_xxx_rec.yyy and IB_SA_XXX_REC_YYY).

>From V1, we have:

+struct ib_pma_portcounters_ext {
..
+       __be64 port_unicast_xmit_packets;
..
+#define IB_PMA_SELX_PORT_UNI_XMIT_PACKETS       cpu_to_be16(0x0010)

at this point, you're patches look good to me and are an improvement over 
what's there now.  So, I'd file this comment as a future nice to have.

- Sean
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to