> > -          Remove the pointer to the ibv_send_wr_ext pointer from the wr 
> > union
> > in ibv_send_wr, and put the ibv_send_wr (less the duplicated data 
> > structures) after the union, with the usual comp_mask flag to indicate what 
> > is supported.
> > This would be our #1 preference, because of the performance implications.
> > 
> > -          Remove the pointer to the ibv_send_wr_ext pointer from the wr 
> > union
> > in ibv_send_wr, and put pointers to relevant structs (task, qp (maybe 
> > should be named transport), and op, in the current example) after the 
> > union, with the usual comp_mask flag to indicate what is supported.  
> > This would be our second preference.
> > 
> > What do you think here ?
> 
> How are you proposing adding a comp_mask and extending the structure size 
> while remaining backward compatible?  A new extended opcode?  New send_flags ?

Previously we had agreed to use a new send_flag , IBV_SEND_EXTENDED, which 
would indicate the presence of the extended data structure.  With new 
functionality, there may also be new extended opcodes, but this is not a 
requirement.


--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to