On 7/28/2015 1:57 PM, Haggai Eran wrote:
Hi Sagi,

On 22/07/2015 09:55, Sagi Grimberg wrote:
Signed-off-by: Sagi Grimberg <sa...@mellanox.com>
---
  drivers/infiniband/hw/mlx5/mlx5_ib.h |  5 ++++
  drivers/infiniband/hw/mlx5/mr.c      | 45 ++++++++++++++++++++++++++++++++++++
  2 files changed, 50 insertions(+)

diff --git a/drivers/infiniband/hw/mlx5/mlx5_ib.h 
b/drivers/infiniband/hw/mlx5/mlx5_ib.h
index c2916f1..df5e959 100644
--- a/drivers/infiniband/hw/mlx5/mlx5_ib.h
+++ b/drivers/infiniband/hw/mlx5/mlx5_ib.h
@@ -315,6 +315,11 @@ enum mlx5_ib_mtt_access_flags {

  struct mlx5_ib_mr {
        struct ib_mr            ibmr;
+       u64                     *pl;
+       __be64                  *mpl;
+       dma_addr_t              pl_map;
Nit: could you choose more descriptive names for these fields? It can be
difficult to understand what they mean just based on the acronym.

OK - I'll name it better in v1.


+       int                     ndescs;
This one isn't used in this patch, right?

Not in this patch - I can move it.

Thanks!
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to