> @@ -127,9 +127,8 @@ static struct iscsi_param *iscsi_set_default_param(struct 
> iscsi_param_list *para
>               char *name, char *value, u8 phase, u8 scope, u8 sender,
>               u16 type_range, u8 use)
>  {
> -     struct iscsi_param *param = NULL;
> +     struct iscsi_param *param;
>  
>       param = kzalloc(sizeof(struct iscsi_param), GFP_KERNEL);
>       if (!param) {
>               pr_err("Unable to allocate memory for parameter.\n");
> 
> 
> This way it would be _far_ more readable.

I guess that there are some opinions available for this implementation detail.


> IMHO one should have a 1 action per line of code style

How often do you care for such style issues?


> and only assign values in at declaration time if really necessary.

Which is or might become the official Linux coding style recommendation
for this aspect?


> But what is the benefit from this? Is it fixing a (hypothetical) bug?

I find the shown null pointer initialisation just needless.

Regards,
Markus

--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to