Hello,

On Thu, Jul 07, 2016 at 01:19:06AM +0800, tom.t...@gmail.com wrote:
> @@ -1071,7 +1072,7 @@ static inline unsigned ata_set_lba_range_entries(void 
> *_buffer,
>       __le64 *buffer = _buffer;
>       unsigned i = 0, used_bytes;
>  
> -     while (i < buf_size / 8 ) { /* 6-byte LBA + 2-byte range per entry */
> +     while (i < buf_size) {

Please rename @buf_size.  It's confusing for a variable named size to
contain something other than bytes.

Thanks.

-- 
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to