> /** > - * bsg_destroy_job - routine to teardown/delete a bsg job > + * bsg_teardown_job - routine to teardown a bsg job > * @job: bsg_job that is to be torn down > */ > -static void bsg_destroy_job(struct kref *kref) > +static void bsg_teardown_job(struct kref *kref)
Why this rename? The destroy name seems to be one of the most common patterns for the kref_put callbacks. Otherwise this looks fine: Reviewed-by: Christoph Hellwig <h...@lst.de>