Am 21.08.2015 03:34, schrieb Siarhei Siamashka:
My compiler happens to be anal about this:

fel.c: In function ‘aw_fel_process_spl_and_uboot’:
fel.c:838:11: warning: comparison between signed and unsigned integer
expressions [-Wsign-compare] if (size > SPL_LEN_LIMIT)
            ^

This warning can be suppressed by changing:

-static const int SPL_LEN_LIMIT = 0x8000;
+#define SPL_LEN_LIMIT 0x8000

Also I think that a common naming convention when writing C code
is to reserve uppercase identifiers for macros.


[...]
If the compiler warning is removed, then this is
Acked-by: Siarhei Siamashka <siarhei.siamas...@gmail.com>

There is no need to re-send the patch for the "static const int" to
"define" change. I can do this adjustment when pushing it to git in
a day or two (unless anybody has objections).


Thanks! As i just had a peek into their sources: Maybe we should
add a small note (comment), that this value needs to correspond
whatever U-Boot sets CONFIG_SPL_PAD_TO to (in
include/configs/sunxi-common.h)?

Regards, B. Nortmann

--
You received this message because you are subscribed to the Google Groups 
"linux-sunxi" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to linux-sunxi+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to