On Thu Sep 17, 2026 at 12:22 PM EDT, Lorenzo Stoakes (ARM) wrote: > Replace the open-coded VMA_SPECIAL_FLAGS check in the VMA merge logic with > two new functions vma_flags_can_merge() and vma_can_merge() and update the > merge logic to use the former. > > This abstracts the check and expresses it in terms of the desired behaviour > rather than an arbitrary and confusing VMA flag. > > This also lays the groundwork for making further improvements in VMA flag > usage. > > Also update the userland VMA tests to reflect the change. > > No functional change intended. > > Signed-off-by: Lorenzo Stoakes (ARM) <[email protected]> > --- > include/linux/mm.h | 21 +++++++++++++++++++++ > mm/vma.c | 19 +++++++++++-------- > tools/testing/vma/include/dup.h | 5 +++++ > 3 files changed, 37 insertions(+), 8 deletions(-) > LGTM.
Reviewed-by: Zi Yan <[email protected]> -- Best Regards, Yan, Zi
