On 10/2/26 09:02, David Hildenbrand (Arm) wrote: > On 10/2/26 08:59, David Hildenbrand (Arm) wrote: >> On 9/17/26 18:22, Lorenzo Stoakes (ARM) wrote: >>> Introduce vma[_flags]_is_persistent() for the purposes of identifying >>> mappings that are persistent in the sense that bytes to the mapping stay >>> there, and bytes read from the mapping are the same unless changed by >>> actions taken by userland. >> >> That's extremely confusing, sorry. We have to find a better name for that. >> >> Is this really all about user pages (pagecache, anon) that we would find >> through >> the rmap? >> > > It's also about droppable mappings AFAIKs. How many more users will we have > for > that function? > > If it's "no others" then please don't add a helper function with misleading > names for it and just keep the special "dumpable" check in the new form in > madvise_vma_behavior().
Talking to myself ... the more usage I see of the vma_is_persistent() the more I think this shouldn't be a helper at all. Especially not one with such a confusing name :P -- Cheers, David
