On Wed, 30 Sep 2026 15:00:05 +0000 [email protected] wrote: > > > diff --git a/include/trace/events/qpace.h b/include/trace/events/qpace.h > > new file mode 100644 > > index 0000000000000..3f0ccdb8f2060 > > --- /dev/null > > +++ b/include/trace/events/qpace.h > > @@ -0,0 +1,99 @@ > > +/* SPDX-License-Identifier: GPL-2.0-only */ > > +/* > > + * Copyright (c) Qualcomm Technologies, Inc. and/or its subsidiaries. > > + */ > > + > > +#undef TRACE_SYSTEM > > +#define TRACE_SYSTEM qpace > > + > > +#if !defined(_TRACE_QPACE_H) || defined(TRACE_HEADER_MULTI_READ) > > +#define _TRACE_QPACE_H > > +#include <linux/tracepoint.h> > > + > > +TRACE_EVENT(start_qpace_urgent_decompress, > > [Severity: Low] > Does this tracepoint name violate the mandatory subsystem_event naming > convention by using an action prefix instead of the subsystem prefix?
There is no mandatory subsystem_event naming convention. It just should be unique. The naming is fine. -- Steve > > Could these be renamed to use the subsystem prefix, such as > qpace_start_urgent_decompress? >
