This is a short series of bugfixes for FunctionFS.

The first patch fixes the problem found by Dan Carpenter (or his automatic
tool?) - if ffs_dev is checked for being NULL it should be done so
consistently throughout the ffs_release_dev().

The second patch is a code style cleanup.

ffs_alloc_dev() and ffs_free_dev() are used only in f_fs.c, so
they can be static and their prototypes in u_fs.h are not necessary,
this is covered in the third patch.

The fourth patch introduces a consistent naming scheme with regard to
taking the ffs_lock - if a function has to be called with the lock
taken, its name starts with an underscore.

v1..v2:

- split the first patch into a fix proper and code cleanup

Andrzej Pietrasiewicz (4):
  usb: gadget: FunctionFS: dereference ffs_dev conditionally
  usb: gadget: code cleanup
  usb: gadget: FunctionFS: staticize functions used only in f_fs.c
  usb: gadget: FunctionFS: use consistent naming with regard to
    ffs_lock

 drivers/usb/gadget/f_fs.c |   39 +++++++++++++++++++++------------------
 drivers/usb/gadget/u_fs.h |    2 --
 2 files changed, 21 insertions(+), 20 deletions(-)

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to