On Thu, Jan 02, 2014 at 05:13:31PM +0100, Krzysztof Opasiak wrote:
> Surround header with include guards to protect against
> multiple inclusion.
> 
> Signed-off-by: Krzysztof Opasiak <k.opas...@samsung.com>
> ---
>  include/gadget/gadget.h |    4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/include/gadget/gadget.h b/include/gadget/gadget.h
> index 9bca97e..f3c08e9 100644
> --- a/include/gadget/gadget.h
> +++ b/include/gadget/gadget.h
> @@ -14,6 +14,9 @@
>   * Lesser General Public License for more details.
>   */
>  
> +#ifndef __GADGET_H__
> +#define __GADGET_H__

Please rename these to __USBG_H__ due to the library rename.

> +
>  #include <dirent.h>
>  #include <sys/queue.h>
>  #include <netinet/ether.h>
> @@ -438,3 +441,4 @@ extern void gadget_set_net_qmult(struct function *f, int 
> qmult);
>  /**
>   * @}
>   */
> +#endif //__GADGET_H__
> -- 
> 1.7.9.5
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to