On 11/10/2014 04:26 PM, Cong Wang wrote:
On Mon, Nov 10, 2014 at 11:51 AM, Alexander Duyck
<alexander.h.du...@redhat.com> wrote:
This patch implements __netdev_alloc_pages and __netdev_alloc_page.  These
are meant to replace the __skb_alloc_pages and __skb_alloc_page functions.
The reason for doing this is that it occurred to me that __skb_alloc_page is
supposed to be passed an sk_buff pointer, but it is NULL in all cases where
it is used.  Worse is that in the case of ixgbe it is passed NULL via the
sk_buff pointer in the rx_buffer info structure which means the compiler is
not correctly stripping it out.
These netdev_*() have nothing related with struct net_device, please
find a better prefix. Also, they are in skbuff.h, you perhaps want to move them
to netdevice.h.

The netdev_ prefix is really meant indicate where they are supposed to be used, not so much the arguments being passed, and the fact that historically this is what we had back in the kernel a couple years ago. I suppose I could rename them to __dev_alloc_page(s) and dev_alloc_page(s) since that seems to be the precedent for how this is handled for skb's. I'll submit something tomorrow if there aren't any other name requests.

I would prefer to keep them in skbuff.h since this is buffer allocation that will later be handed off via either build_skb or skb_add_rx_frag to an sk_buff.

Thanks,

Alex


--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to