The commit 47d3946ea220
        usb: dwc3: refactor gadget endpoint count calculation
refactored dwc3_gadget_init_endpoints() and in particular changed in our
out endpoint numbering to be through. It's not always convenient and
makes code a slightly harder to read.

Introduce temporary variable to make it easier to understand what is
going on inside function.

Replace implicit direction check via epnum with explicit use of direction
variable.

While here, replace %d to %u when compounding endpoint name since we are
using unsigned type.

Signed-off-by: Andy Shevchenko <andriy.shevche...@linux.intel.com>
---
 drivers/usb/dwc3/gadget.c | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
index aea9a5b948b4..9b5ce474f641 100644
--- a/drivers/usb/dwc3/gadget.c
+++ b/drivers/usb/dwc3/gadget.c
@@ -1992,6 +1992,7 @@ static int dwc3_gadget_init_endpoints(struct dwc3 *dwc, 
u8 num)
 
        for (epnum = 0; epnum < num; epnum++) {
                bool                    direction = epnum & 1;
+               u8                      inout = epnum >> 1;
 
                dep = kzalloc(sizeof(*dep), GFP_KERNEL);
                if (!dep)
@@ -2003,7 +2004,7 @@ static int dwc3_gadget_init_endpoints(struct dwc3 *dwc, 
u8 num)
                dep->regs = dwc->regs + DWC3_DEP_BASE(epnum);
                dwc->eps[epnum] = dep;
 
-               snprintf(dep->name, sizeof(dep->name), "ep%d%s", epnum >> 1,
+               snprintf(dep->name, sizeof(dep->name), "ep%u%s", inout,
                                direction ? "in" : "out");
 
                dep->endpoint.name = dep->name;
@@ -2015,11 +2016,11 @@ static int dwc3_gadget_init_endpoints(struct dwc3 *dwc, 
u8 num)
 
                spin_lock_init(&dep->lock);
 
-               if (epnum == 0 || epnum == 1) {
+               if (inout == 0) {
                        usb_ep_set_maxpacket_limit(&dep->endpoint, 512);
                        dep->endpoint.maxburst = 1;
                        dep->endpoint.ops = &dwc3_gadget_ep0_ops;
-                       if (!epnum)
+                       if (!direction)
                                dwc->gadget.ep0 = &dep->endpoint;
                } else if (direction) {
                        int mdwidth;
@@ -2031,7 +2032,7 @@ static int dwc3_gadget_init_endpoints(struct dwc3 *dwc, 
u8 num)
                        /* MDWIDTH is represented in bits, we need it in bytes 
*/
                        mdwidth /= 8;
 
-                       size = dwc3_readl(dwc->regs, DWC3_GTXFIFOSIZ(epnum >> 
1));
+                       size = dwc3_readl(dwc->regs, DWC3_GTXFIFOSIZ(inout));
                        size = DWC3_GTXFIFOSIZ_TXFDEF(size);
 
                        /* FIFO Depth is in MDWDITH bytes. Multiply */
@@ -2073,7 +2074,7 @@ static int dwc3_gadget_init_endpoints(struct dwc3 *dwc, 
u8 num)
                                return ret;
                }
 
-               if (epnum == 0 || epnum == 1) {
+               if (inout == 0) {
                        dep->endpoint.caps.type_control = true;
                } else {
                        dep->endpoint.caps.type_iso = true;
-- 
2.11.0

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to