Hi Johannes,

On ke, 2014-10-29 at 16:53 +0100, Johannes Berg wrote:
> On Wed, 2014-10-29 at 16:50 +0100, Johannes Berg wrote:
> > On Mon, 2014-10-27 at 12:44 +0200, Jukka Rissanen wrote:
> > 
> > > +static void mcast_msg(struct sk_buff *mcast_skb, struct genl_info *info)
> > > +{
> > > + if (info)
> > > +         genl_notify(&hwsim_genl_family, mcast_skb,
> > > +                     genl_info_net(info), info->snd_portid,
> > > +                     HWSIM_MCGRP_CONFIG, info->nlhdr, GFP_KERNEL);
> > > + else
> > > +         genlmsg_multicast(&hwsim_genl_family, mcast_skb, 0,
> > > +                           HWSIM_MCGRP_CONFIG, GFP_KERNEL);
> > > +}
> > 
> > Also - given the parameters and what this does, that's a bad name for
> > the function. Never mind that it doesn't have any sort of identifier
> > (say hwsim_ prefix), it doesn't even do what it says it does.
> 
> Or maybe it does? I'm unsure what genl_notify() does...

Yes, genl_notify() will eventually call nlmsg_notify() which will
multicast the message because we have set the group id in the call.

http://lxr.free-electrons.com/source/net/netlink/af_netlink.c#L2856


Cheers,
Jukka


--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to