Hi Arend, On Fri, Sep 01, 2017 at 11:30:59PM +0200, Arend van Spriel wrote: > > > Hi Rob, > > > > > > Actually the Broadcom wifi chips themselves are discoverable. So once the > > > driver has access to the register space of the device it can determine the > > > actual chip, its revision, and exactly what cores (and their revision) are > > > present in the chip. Hence there is a single compatible string as there is > > > no need to convey the same information through device tree data. > > > > In my expereince this how it seems to work. > > > > I jsut discovered s/brcm,bcm4329-fmac/brcm/ can load the broadcom driver. > > > > brcmf: wifi@1 { > > reg = <1>; > > compatible = "brcm"; > > }; > > > > This looks better to me. Maxime, Would this work? > > I have no idea what you are saying here. To what exactly do you apply that > substitute. In brcmfmac I have:
Thanks for pointing me to the relevent code. I was asking about DT support I submitted. > > if (!np || bus_type != BRCMF_BUSTYPE_SDIO || > !of_device_is_compatible(np, "brcm,bcm4329-fmac")) > return; > > In my perception using "brcm" goes against DT compatible naming convention. It seems the driver has a special place holder, bcm4329-fmac. I am still wondering what is acceptable in the DT. compatible = ""brcm,bcm4329-fmac"; or compatible = "brcm"; The last one does not generate any warnings. Here it the DT I am proposing. https://patchwork.kernel.org/patch/9937263/ regards, -antony