[EMAIL PROTECTED] wrote:
> Quoting Corey Osgood <[EMAIL PROTECTED]>:
>
>> [EMAIL PROTECTED] wrote:
>>> Quoting Corey Osgood <[EMAIL PROTECTED]>:
>>>
>>>> [EMAIL PROTECTED] wrote:
>>>>> static void lpc_init(struct device *dev)
>>>>>  {
>>>>> -    uint8_t byte;
>>>>> -    int pwr_on = -1;
>>>>> -    int nmi_option;
>>>>> +    unsigned ich_model;
>>>> uint_16 or u16 please
>>>>
>>> I tried that originally but got a build error. That's why I used
>>> unsigned. uint_16 is defined in the actual function anyways.

Meant to comment before, oops. I meant uint16_t, of course. Not sure why
there would be build errors from that...

>>>>
>>>>>  #define PMBASE            0x40
>>>>> -#define PM_BASE_ADDR        0x1100
>>>>>  #define ACPI_CNTL        0x44
>>>>>  #define BIOS_CNTL        0x4E
>>>>>  #define GPIO_BASE        0x58
>>>>> -#define GPIO_BASE_ADDR        0x1180
>>>>> +#define GPIOBASE        0x48
>>>>
>>>> What's GPIO_BASE vs GPIOBASE? Better names possible?
>>>>
>>> GPIOBASE is what intel calls it in the ICH6-9 datasheets.
>>> What should I name this??
>>
>> GPIOBASE makes perfect sense, the confusion is, what's the difference
>> between that and GPIO_BASE
>>
> The register address 0x58 (ICH0-ICH5) vs 0x48 (ICH6-ICH9).

Okay, can we do GPIO_BASE_ICH0_5 and then GPIO_BASE_ICH6_9? And similar
for GPIO_CNTL?

After that, swear to god, done nitpicking.

Thanks,
Corey

-- 
linuxbios mailing list
linuxbios@linuxbios.org
http://www.linuxbios.org/mailman/listinfo/linuxbios

Reply via email to