linuxppc-dev
Thread
Date
Earlier messages
Messages by Thread
[PATCH v2 0/3] tty: replace page allocator calls with k[mz]alloc()
Mike Rapoport (Microsoft)
[PATCH v2 3/3] tty: hvcs: replace __get_free_page() with kmalloc()
Mike Rapoport (Microsoft)
Re: [PATCH v13 3/8] powerpc/bpf: fix buffer overflow in JIT for large BPF programs
bot+bpf-ci
[PATCH v3 net-next 0/8] net: dsa: netc: add PTP support for NETC switch
wei . fang
[PATCH v3 net-next 2/8] ptp: netc: remove unnecessary pcie_flr() call in probe
wei . fang
[PATCH v3 net-next 3/8] ptp: netc: export netc_timer_get_current_time() for cross-driver use
wei . fang
[PATCH v3 net-next 5/8] net: dsa: netc: check return value of ntmp_ipft_delete_entry()
wei . fang
[PATCH v3 net-next 4/8] net: dsa: netc: use entry ID instead of pointer to track host flood rule
wei . fang
[PATCH v3 net-next 6/8] net: dsa: netc: enable ingress port filtering lookup by default
wei . fang
[PATCH v3 net-next 7/8] net: dsa: netc: add PTP two-step timestamping support
wei . fang
[PATCH v3 net-next 1/8] ptp: netc: use ioread64_lo_hi/iowrite64_lo_hi for 64-bit register access
wei . fang
Re: [PATCH v13 8/8] selftests/bpf: Add tailcall verifier selftest for powerpc64
bot+bpf-ci
[PATCH 01/11] mm/sparse-vmemmap: introduce CONFIG_SPARSEMEM_VMEMMAP_OPTIMIZATION
Muchun Song
[PATCH 11/11] Documentation/mm: update DAX vmemmap deduplication docs
Muchun Song
[PATCH 08/11] powerpc/mm: switch device DAX to shared tail vmemmap pages
Muchun Song
[PATCH 07/11] mm/sparse-vmemmap: move HVO helpers to a public header
Muchun Song
[PATCH 06/11] mm/sparse-vmemmap: switch device DAX to shared tail vmemmap pages
Muchun Song
[PATCH 04/11] mm/sparse-vmemmap: prepare DAX vmemmap population for section orders
Muchun Song
[PATCH 02/11] mm/sparse-vmemmap: factor out shared vmemmap tail page allocation
Muchun Song
[PATCH 03/11] mm/sparse-vmemmap: open-code init_compound_tail()
Muchun Song
[PATCH v13 7/8] selftests/bpf: Enable verifier selftest for powerpc64
Saket Kumar Bhaskar
[PATCH v13 4/8] powerpc/bpf: fix alignment of long branch trampoline address
Saket Kumar Bhaskar
Re: [PATCH v13 4/8] powerpc/bpf: fix alignment of long branch trampoline address
bot+bpf-ci
[PATCH v13 2/8] powerpc64/bpf: fix percpu private stack leak on JIT failure
Saket Kumar Bhaskar
[PATCH v13 6/8] selftests/bpf: Fix powerpc JIT disassembly failure
Saket Kumar Bhaskar
[PATCH v13 1/8] powerpc64/bpf: fix compare instruction emitted for tailcall
Saket Kumar Bhaskar
Re: [PATCH] powerpc/64s: Fix the vector number in comments for h_facility_unavailable
Gautam Menghani
[PATCH v4 0/5] powerpc/eeh: Add RTAS-based error injection support on pSeries
Narayana Murty N
[PATCH v4 2/5] vfio/spapr_tce: Normalize EEH IOA error injection addresses
Narayana Murty N
[PATCH v4 1/5] powerpc/rtas: Handle ibm,open-errinjct return format
Narayana Murty N
[PATCH v4 3/5] powerpc/pseries/eeh: Add RTAS error validation helpers
Narayana Murty N
[PATCH v4 4/5] powerpc/pseries/eeh: Implement RTAS-based EEH error injection
Narayana Murty N
[PATCH v4 5/5] powerpc/powernv/eeh: Map VFIO EEH error injection to OPAL
Narayana Murty N
[PATCH 0/8] mm: Drop pxd_ERROR()
Anshuman Khandual
[PATCH 2/8] mm: Stop using pxd_ERROR()
Anshuman Khandual
[PATCH 1/8] mm: Make ptval_to_str() generally available
Anshuman Khandual
[PATCH 3/8] loongarch/mm: Stop using pte_ERROR()
Anshuman Khandual
[PATCH 4/8] parisc/mm: Directly use generic [pmd|pgd]_clear_bad()
Anshuman Khandual
[PATCH 6/8] sh/mm: Stop using [p4d|pud|pmd]_ERROR()
Anshuman Khandual
[PATCH 8/8] mm: Drop pxd_ERROR()
Anshuman Khandual
[PATCH 7/8] sh/mm: Stop using pgd_ERROR()
Anshuman Khandual
[PATCH 5/8] sh/mm: Stop using pte_ERROR()
Anshuman Khandual
Re: [PATCH 0/8] mm: Drop pxd_ERROR()
John Paul Adrian Glaubitz
Re: [PATCH 0/8] mm: Drop pxd_ERROR()
Anshuman Khandual
[PATCH] PCI/AER: Fix struct pci_dev reference leak in aer_process_err_devices()
Priyank Rathod
Re: [PATCH] PCI/AER: Fix struct pci_dev reference leak in aer_process_err_devices()
Lukas Wunner
Re: [PATCH] PCI/AER: Fix struct pci_dev reference leak in aer_process_err_devices()
Lukas Wunner
Re: [PATCH] PCI/AER: Fix struct pci_dev reference leak in aer_process_err_devices()
Priyank Rathod
[PATCH] powerpc: Do not restore KUAP in arch_exit_to_user_mode_prepare()
Ritesh Harjani (IBM)
Re: [PATCH] powerpc: Do not restore KUAP in arch_exit_to_user_mode_prepare()
Mukesh Kumar Chaurasiya
[PATCH 0/3] tty: replace page allocator calls with k[mz]alloc()
Mike Rapoport (Microsoft)
[PATCH 1/3] tty: port: replace get_zeroed_page() with kzalloc()
Mike Rapoport (Microsoft)
[PATCH 2/3] serial: core: replace get_zeroed_page() with kzalloc()
Mike Rapoport (Microsoft)
Re: [PATCH 2/3] serial: core: replace get_zeroed_page() with kzalloc()
Jiri Slaby
Re: [PATCH 2/3] serial: core: replace get_zeroed_page() with kzalloc()
Mike Rapoport
[PATCH 3/3] tty: hvcs: replace __get_free_page() with kmalloc()
Mike Rapoport (Microsoft)
[PATCH 0/4] char/misc: replace page allocator calls with k[mz]alloc()
Mike Rapoport (Microsoft)
[PATCH 1/4] char: xilinx_hwicap: replace page allocator calls with k[mz]alloc()
Mike Rapoport (Microsoft)
[PATCH 2/4] char: xillybus: replace __get_free_pages() with kmalloc()
Mike Rapoport (Microsoft)
[PATCH 4/4] platform: goldfish: pipe: replace __get_free_page() with kmalloc()
Mike Rapoport (Microsoft)
[PATCH 3/4] misc: ibmvmc: replace get_zeroed_page() with kzalloc()
Mike Rapoport (Microsoft)
[PATCH v2 0/7] jffs2: extend write verification to all write paths
zhouminqiang
[PATCH v2 4/7] jffs2: add write verification to direct page writes in flash_writev
zhouminqiang
[PATCH v2 7/7] jffs2: add runtime toggle for write verification
zhouminqiang
[PATCH v2 6/7] jffs2: rename CONFIG_JFFS2_FS_WBUF_VERIFY to CONFIG_JFFS2_FS_WRITE_VERIFY
zhouminqiang
[PATCH v2 1/7] jffs2: wbuf: clear wbuf on recovery failure paths
zhouminqiang
[PATCH v2 5/7] jffs2: add write verification to NOR direct write paths
zhouminqiang
[PATCH v2 2/7] jffs2: replace per-superblock verify buffer with per-write buffer
zhouminqiang
[PATCH v2 3/7] jffs2: write verify: add byte-by-byte comparison on mismatch
zhouminqiang
[PATCH] powerpc: Don't drop _TIF_RESTOREALL on syscall restart
Ritesh Harjani (IBM)
Re: [PATCH] powerpc: Don't drop _TIF_RESTOREALL on syscall restart
Venkat Rao Bagalkote
Re: [PATCH] powerpc: Don't drop _TIF_RESTOREALL on syscall restart
Mukesh Kumar Chaurasiya
[PATCH v2] powerpc/boot: Drop unused min_t()/max_t() helpers
Thorsten Blum
Re: [RFC PATCH 0/9] arm64: Allocate .text and .init.text together
Petr Pavlu
Re: [RFC PATCH 0/9] arm64: Allocate .text and .init.text together
Ard Biesheuvel
[BUG] VFIO amdgpu passthrough fails on PowerNV in XIVE mode
Timothy Pearson
[PATCH v4] ppc/fadump: collect dump when CPU_STATE_DATA is less than reserved
Shivang Upadhyay
[PATCH] usb: gadget: fsl_qe_udc: bound RX frame copies to the request's remaining space
Wang Yan
[PATCH 6.6.y] Revert "usb: phy: fsl-usb: Fix use-after-free in delayed work during device removal"
Ralf Lici
Re: [PATCH 6.6.y] Revert "usb: phy: fsl-usb: Fix use-after-free in delayed work during device removal"
Sasha Levin
[PATCH 6.1.y] Revert "usb: phy: fsl-usb: Fix use-after-free in delayed work during device removal"
Ralf Lici
Re: [PATCH 6.1.y] Revert "usb: phy: fsl-usb: Fix use-after-free in delayed work during device removal"
Sasha Levin
[PATCH] powerpc/entry: Clear TIF_SYSCALL_RET before syscall error return
Shrikanth Hegde
Re: [PATCH] powerpc/entry: Clear TIF_SYSCALL_RET before syscall error return
Shivaprasad G Bhat
Re: [PATCH] powerpc/entry: Clear TIF_SYSCALL_RET before syscall error return
Mukesh Kumar Chaurasiya
[REGRESSION] 6.1.y/6.6.y: fsl-usb fails to build
Ralf Lici
Re: [REGRESSION] 6.1.y/6.6.y: fsl-usb fails to build
Greg Kroah-Hartman
Re: [REGRESSION] 6.1.y/6.6.y: fsl-usb fails to build
Ralf Lici
[PATCH v2] powerpc/configs: Add debug configs for debugging
Gautam Menghani
Re: [PATCH v2] powerpc/configs: Add debug configs for debugging
Mukesh Kumar Chaurasiya
[PATCH 1/2] scsi: ibmvfc: fix kernel-doc name for ibmvfc_scsi_relogin()
Muhammad Falak R Wani
[PATCH 2/2] scsi: ibmvfc: document protocol parameter of ibmvfc_alloc_target()
Muhammad Falak R Wani
Re: [PATCH 2/2] scsi: ibmvfc: document protocol parameter of ibmvfc_alloc_target()
Dave Marquardt
Re: [PATCH 2/2] scsi: ibmvfc: document protocol parameter of ibmvfc_alloc_target()
Tyrel Datwyler
Re: [PATCH 1/2] scsi: ibmvfc: fix kernel-doc name for ibmvfc_scsi_relogin()
Dave Marquardt
Re: [PATCH 1/2] scsi: ibmvfc: fix kernel-doc name for ibmvfc_scsi_relogin()
Tyrel Datwyler
Re: [PATCH 1/2] scsi: ibmvfc: fix kernel-doc name for ibmvfc_scsi_relogin()
Martin K. Petersen (Oracle)
[PATCH v3] ppc/fadump: collect dump if the collected size is lesser than reserved
Shivang Upadhyay
Re: [PATCH v3] ppc/fadump: collect dump if the collected size is lesser than reserved
Shivang Upadhyay
[PATCH 0/8] Extend PKWM to support user-created wrapping keys
Srish Srinivasan
[PATCH 2/8] pseries/plpks: fix error handling in plpks_read_var()
Srish Srinivasan
[PATCH 1/8] pseries/plpks: update PKS documentation and maintainer entry
Srish Srinivasan
[PATCH 5/8] pseries/plpks: hide wrapping_features when unsupported
Srish Srinivasan
[PATCH 4/8] pseries/plpks: rename the default wrapping key macro
Srish Srinivasan
[PATCH 6/8] pseries/plpks: add HCALLs for PKWM wrapping key life cycle management
Srish Srinivasan
Re: [PATCH 6/8] pseries/plpks: add HCALLs for PKWM wrapping key life cycle management
R Nageswara Sastry
[PATCH 7/8] keys/trusted_keys: enable PKWM wrapping key selection by label
Srish Srinivasan
[PATCH 8/8] pseries/plpks/wrapkey: expose PKWM wrapping key management to userspace via sysfs
Srish Srinivasan
[PATCH 3/8] pseries/plpks: improve type consistency and parameter validation
Srish Srinivasan
powerpc: userspace processes crash on abort() from libc.so.6
Shivaprasad G Bhat
Re: powerpc: userspace processes crash on abort() from libc.so.6
Shrikanth Hegde
Re: powerpc: userspace processes crash on abort() from libc.so.6
Shivaprasad G Bhat
[PATCH] powerpc/configs: Add debug configs for debugging
Gautam Menghani
[PATCH 0/2] powerpc: remove spufs coredump support
Christian Brauner
[PATCH 1/2] powerpc: remove coredump support
Christian Brauner
Re: [PATCH 0/2] powerpc: remove spufs coredump support
Arnd Bergmann
Re: [PATCH 0/2] powerpc: remove spufs coredump support
Christian Brauner
[PATCH 2/2] coredump: stop unsharing the file descriptor table
Christian Brauner
[PATCH v2] ppc/fadump: collect dump if the collected size is lesser than reserved
Shivang Upadhyay
Re: [PATCH v2] ppc/fadump: collect dump if the collected size is lesser than reserved
Sourabh Jain
Re: [PATCH v2] ppc/fadump: collect dump if the collected size is lesser than reserved
Shivang Upadhyay
Re: [PATCH v2] ppc/fadump: collect dump if the collected size is lesser than reserved
Sourabh Jain
[PATCH v3 00/17] crash: Rework and add arm64 crash hotplug support
Jinjie Ruan
[PATCH v3 04/17] arm64: kexec_file: Fix elf_headers memory leak in retry loop
Jinjie Ruan
[PATCH v3 03/17] arm64: kexec_file: Fix CMA page leaks in segment placement retry loops
Jinjie Ruan
[PATCH v3 02/17] kexec: Extract kexec_free_segment_cma() from kimage_free_cma()
Jinjie Ruan
[PATCH v3 05/17] LoongArch: kexec: Fix CMA page leaks in segment placement retry loops
Jinjie Ruan
[PATCH v3 01/17] kexec: Record allocated CMA pages to fix release size mismatch
Jinjie Ruan
[PATCH v3 06/17] LoongArch: kexec_file: Fix elf_headers memory leak in retry loop
Jinjie Ruan
[PATCH v3 10/17] elf: Introduce elf64_phdr_size() helper
Jinjie Ruan
[PATCH v3 07/17] crash_dump: Fix potential double-free of keys_header
Jinjie Ruan
Re: [PATCH v3 07/17] crash_dump: Fix potential double-free of keys_header
Sourabh Jain
Re: [PATCH v3 07/17] crash_dump: Fix potential double-free of keys_header
Jinjie Ruan
[PATCH v3 08/17] crash: Extract crash_get_memory_ranges() helper
Jinjie Ruan
[PATCH v3 09/17] crash: Fix TOCTOU race in crash memory range collection
Jinjie Ruan
[PATCH v3 13/17] crash: Improve elfcorehdr segment identification
Jinjie Ruan
[PATCH v3 12/17] x86/crash: Use num_possible_cpus() for elfcorehdr size
Jinjie Ruan
[PATCH v3 14/17] x86/crash: Simplify crash_load_segments() using crash_extra_elfcorehdr_size()
Jinjie Ruan
[PATCH v3 15/17] crash: Simplify CRASH_MAX_MEMORY_RANGES handling
Jinjie Ruan
[PATCH v3 16/17] arm64: kexec_file: Simplify load_other_segments()
Jinjie Ruan
[PATCH v3 17/17] arm64: crash: Add crash hotplug support
Jinjie Ruan
[PATCH v3 11/17] crash: Introduce crash_extra_elfcorehdr_size() helper
Jinjie Ruan
Re: [PATCH] powerpc/rtas_pci: No hotplug on permanently removed device on pSeries
tasmiya
Re: [PATCH] powerpc/rtas_pci: No hotplug on permanently removed device on pSeries
Harsh Prateek Bora
Re: [PATCH] powerpc/rtas_pci: No hotplug on permanently removed device on pSeries
tasmiya
[PATCH v2 00/13] Make SBR work for CXL Downstream Ports
Fabio M. De Francesco
[PATCH v2 01/13] cxl/pci: Make the HDM and Mem_Enable writes callable from CXL
Fabio M. De Francesco
[PATCH v2 02/13] cxl/hdm: Add function to restore one HDM decoder
Fabio M. De Francesco
[PATCH v2 03/13] cxl/hdm: Add function to restore CXL.mem decode
Fabio M. De Francesco
[PATCH v2 04/13] cxl/hdm: Reprogram the HDM Decoders below a CXL Port
Fabio M. De Francesco
[PATCH v2 07/13] cxl/core: Add region disable and enable for a DPort SBR
Fabio M. De Francesco
[PATCH v2 06/13] drivers/base/memory: Add cxl_offline_memory() to offline a physical range
Fabio M. De Francesco
[PATCH v2 05/13] cxl/core: Restore the HDM decoders below DPort
Fabio M. De Francesco
[PATCH v2 08/13] cxl/core: Collect the regions routed through a DPort
Fabio M. De Francesco
[PATCH v2 09/13] PCI/CXL: Disable and re-enable CXL regions
Fabio M. De Francesco
Re: [PATCH v2 09/13] PCI/CXL: Disable and re-enable CXL regions
Richard Cheng
[PATCH v2 11/13] PCI/DPC: Unbind regions for DPC recovery
Fabio M. De Francesco
Re: [PATCH v2 11/13] PCI/DPC: Unbind regions for DPC recovery
Richard Cheng
[PATCH v2 10/13] PCI/CXL: Clear ACS SV across an SBR of a CXL DPort
Fabio M. De Francesco
Re: [PATCH v2 10/13] PCI/CXL: Clear ACS SV across an SBR of a CXL DPort
Richard Cheng
[PATCH v2 12/13] PCI/CXL: Add a sysfs entry to unmask SBR
Fabio M. De Francesco
[PATCH v2 13/13] PCI/CXL: Refuse an SBR of a CXL DPort unless authorized
Fabio M. De Francesco
Re: [PATCH v2 00/13] Make SBR work for CXL Downstream Ports
Richard Cheng
[PATCH] ALSA: aoa: i2sbus: Check IRQ before requesting it
phucduc . bui
Re: [PATCH] ALSA: aoa: i2sbus: Check IRQ before requesting it
Takashi Iwai
[PATCH v3 0/4] powerpc/kdump: Support high crashkernel reservation
Sourabh Jain
[PATCH v3 2/4] powerpc: move to 64-bit RTAS
Sourabh Jain
[PATCH v3 1/4] powerpc/mmu: do MMU type discovery before crashkernel reservation
Sourabh Jain
[PATCH v3 3/4] powerpc/kdump: consider high crashkernel memory if enabled
Sourabh Jain
[PATCH v3 4/4] powerpc/kdump: add support for high crashkernel reservation
Sourabh Jain
[PATCH] ASoC: fsl_micfil: balance mclk enable/disable
Ștefan Ghețu
Re: [PATCH] ASoC: fsl_micfil: balance mclk enable/disable
Chancel Liu
[PATCH v2] ASoC: fsl_micfil: balance mclk enable/disable
Ștefan Ghețu
[PATCH] docs: ABI: Fix powerpc memtrace Kconfig symbol
Karl Mehltretter
[RFC PATCH v4 0/5] Add perf.data tracepoint events to trace.dat conversion
Tanushree Shah
[RFC PATCH v4 1/5] perf/trace-dat: Add trace.dat export infrastructure
Tanushree Shah
[RFC PATCH v4 2/5] perf/trace-event: Write trace.dat metadata sections during parsing
Tanushree Shah
[RFC PATCH v4 3/5] perf data-convert: Add perf.data to trace.dat conversion backend
Tanushree Shah
[RFC PATCH v4 5/5] perf test: Add test validating trace.dat generated by 'perf data convert --to-trace-dat'
Tanushree Shah
[RFC PATCH v4 4/5] perf data: Add --to-trace-dat option for converting perf.data tracepoint events into trace.dat format
Tanushree Shah
[BUG] Interrupt timing warnings in pSeries guest on PowerNV host
Timothy Pearson
Re: [BUG] Interrupt timing warnings in pSeries guest on PowerNV host
Shrikanth Hegde
[PATCH v2] PCI: quirks: Add warm reset quirk for IBM Spyre accelerator
Avinash Roy
[PATCH 0/6] coredump: select memory types per request
Christian Brauner
[PATCH 2/6] tools: sync coredump.h header
Christian Brauner
[PATCH 4/6] selftests/coredump: test COREDUMP_MEMORY_TYPES
Christian Brauner
[PATCH 6/6] selftests/coredump: test failed handshakes
Christian Brauner
[PATCH 1/6] coredump: select memory types to include
Christian Brauner
[PATCH 3/6] selftests/coredump: simplify the refusal tests
Christian Brauner
[PATCH 5/6] selftests/coredump: improve coredump size negotiation tests
Christian Brauner
[RFC PATCH 0/3] powerpc: initial support for Kexec HandOver (KHO)
Sourabh Jain
[RFC PATCH 1/3] kernel/liveupdate: make KEXEC_HANDOVER depend on KEXEC_FILE instead of selecting it
Sourabh Jain
[RFC PATCH 3/3] powerpc/kho: exclude THP and HUGETLB_PAGE
Sourabh Jain
Re: [RFC PATCH 3/3] powerpc/kho: exclude THP and HUGETLB_PAGE
Pratyush Yadav
Re: [RFC PATCH 3/3] powerpc/kho: exclude THP and HUGETLB_PAGE
Sourabh Jain
[RFC PATCH 2/3] powerpc: add support for Kexec HandOver (KHO)
Sourabh Jain
Re: [RFC PATCH 2/3] powerpc: add support for Kexec HandOver (KHO)
Pratyush Yadav
Re: [RFC PATCH 2/3] powerpc: add support for Kexec HandOver (KHO)
Sourabh Jain
Re: [RFC PATCH 2/3] powerpc: add support for Kexec HandOver (KHO)
Sourabh Jain
Re: [PATCH 07/15] RISC-V: Remove AT_VECTOR_SIZE_ARCH from UAPI
Paul Walmsley
Earlier messages