On Wed, Apr 01, 2020 at 03:12:53PM +0530, Naveen N. Rao wrote: > Hi Gautham, > > Gautham R. Shenoy wrote: > >From: "Gautham R. Shenoy" <e...@linux.vnet.ibm.com> > > > >Currently when CPU goes idle, we take a snapshot of PURR via > >pseries_idle_prolog() which is used at the CPU idle exit to compute > >the idle PURR cycles via the function pseries_idle_epilog(). Thus, > >the value of idle PURR cycle thus read before pseries_idle_prolog() and > >after pseries_idle_epilog() is always correct. > > > >However, if we were to read the idle PURR cycles from an interrupt > >context between pseries_idle_prolog() and pseries_idle_epilog() (this will > >be done in a future patch), then, the value of the idle PURR thus read > >will not include the cycles spent in the most recent idle period. > > > >This patch addresses the issue by providing accessor function to read > >the idle PURR such such that it includes the cycles spent in the most > >recent idle period, if we read it between pseries_idle_prolog() and > >pseries_idle_epilog(). In order to achieve it, the patch saves the > >snapshot of PURR in pseries_idle_prolog() in a per-cpu variable, > >instead of on the stack, so that it can be accessed from an interrupt > >context. > > > >Signed-off-by: Gautham R. Shenoy <e...@linux.vnet.ibm.com> > >--- > > arch/powerpc/include/asm/idle.h | 47 > > +++++++++++++++++++++++++++------- > > arch/powerpc/platforms/pseries/setup.c | 7 +++-- > > drivers/cpuidle/cpuidle-pseries.c | 15 +++++------ > > 3 files changed, 47 insertions(+), 22 deletions(-) > > > >diff --git a/arch/powerpc/include/asm/idle.h > >b/arch/powerpc/include/asm/idle.h > >index 32064a4c..d4bfb6a 100644 > >--- a/arch/powerpc/include/asm/idle.h > >+++ b/arch/powerpc/include/asm/idle.h > >@@ -5,10 +5,27 @@ > > #include <asm/paca.h> > > > > #ifdef CONFIG_PPC_PSERIES > >-static inline void pseries_idle_prolog(unsigned long *in_purr) > >+DECLARE_PER_CPU(u64, idle_entry_purr_snap); > >+ > >+static inline void snapshot_purr_idle_entry(void) > >+{ > >+ *this_cpu_ptr(&idle_entry_purr_snap) = mfspr(SPRN_PURR); > >+} > >+ > >+static inline void update_idle_purr_accounting(void) > >+{ > >+ u64 wait_cycles; > >+ u64 in_purr = *this_cpu_ptr(&idle_entry_purr_snap); > >+ > >+ wait_cycles = be64_to_cpu(get_lppaca()->wait_state_cycles); > >+ wait_cycles += mfspr(SPRN_PURR) - in_purr; > >+ get_lppaca()->wait_state_cycles = cpu_to_be64(wait_cycles); > >+} > >+ > >+static inline void pseries_idle_prolog(void) > > { > > ppc64_runlatch_off(); > >- *in_purr = mfspr(SPRN_PURR); > >+ snapshot_purr_idle_entry(); > > /* > > * Indicate to the HV that we are idle. Now would be > > * a good time to find other work to dispatch. > >@@ -16,16 +33,28 @@ static inline void pseries_idle_prolog(unsigned long > >*in_purr) > > get_lppaca()->idle = 1; > > } > > > >-static inline void pseries_idle_epilog(unsigned long in_purr) > >+static inline void pseries_idle_epilog(void) > > { > >- u64 wait_cycles; > >- > >- wait_cycles = be64_to_cpu(get_lppaca()->wait_state_cycles); > >- wait_cycles += mfspr(SPRN_PURR) - in_purr; > >- get_lppaca()->wait_state_cycles = cpu_to_be64(wait_cycles); > >+ update_idle_purr_accounting(); > > get_lppaca()->idle = 0; > >- > > ppc64_runlatch_on(); > > } > >+ > >+static inline u64 read_this_idle_purr(void) > >+{ > >+ /* > >+ * If we are reading from an idle context, update the > >+ * idle-purr cycles corresponding to the last idle period. > >+ * Since the idle context is not yet over, take a fresh > >+ * snapshot of the idle-purr. > >+ */ > >+ if (unlikely(get_lppaca()->idle == 1)) { > >+ update_idle_purr_accounting(); > >+ snapshot_purr_idle_entry(); > >+ } > >+ > >+ return be64_to_cpu(get_lppaca()->wait_state_cycles); > >+} > >+ > > I think this and read_this_idle_spurr() from the next patch should be moved > to Patch 4/6, where they are actually used.
The reason I included this function in this patch was to justify why we were introducing snapshotting the purr values in a global per-cpu variable instead of on a stack variable. The reason being that someone might want to read the PURR value from an interrupt context which had woken up the CPU from idle. At this point, since epilog() function wasn't called, the idle PURR count corresponding to this latest idle period would have been accumulated in lppaca->wait_cycles. Thus, this helper function safely reads the value by 1) First updating the lppaca->wait_cycles with the latest idle_purr count. 2) Take a fresh snapshot, since the time from now to the epilog() call is also counted under idle CPU. So the PURR cycle increment during this short period should also be accumulated in lppaca->wait_cycles. prolog() | snapshot PURR | | | Idle | | <----- Interrupt . Read idle PURR ---- update idle PURR; | snapshot PURR; | Read idle PURR. | epilog() update idle PURR > > - Naveen > However, if you feel that moving this function to Patch 4 where it is actually used makes it more readable, I can do that. -- Thanks and Regards gautham.