On Mon Jun 29, 2026 at 3:25 PM EDT, Lorenzo Stoakes wrote: > Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer > to a VMA is confusing. > > Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this > confusion. > > No functional change intended. > > Signed-off-by: Lorenzo Stoakes <[email protected]> > --- > include/linux/mm.h | 4 ++-- > mm/vma.c | 2 +- > mm/vma.h | 2 +- > tools/testing/vma/include/dup.h | 2 +- > 4 files changed, 5 insertions(+), 5 deletions(-) > Makes sense.
Reviewed-by: Zi Yan <[email protected]> -- Best Regards, Yan, Zi
