+       model = "NintendoGameCube";
+       compatible = "nintendo,gamecube";

To date, we've been using the same form for both the model and
compatible properties.  Specifically the <vendor>,<model> form to
maintain the namespace.

That, however, is a) useless; and b) not totally correct.
The "model" property should show an exact model number if available.
You should use the "vendor," thing indeed.

If you don't have any better model # to use, using the same thing
as "compatible" is okay I suppose.  But it's not the _best_ thing
to put here if you have the choice. Maybe you should say "nintendo,RVL-001"
(well, that's Wii, you want the similar thing for NGC, but you get
the point I hope).

+               compatible = "nintendo,flipper";
+               clock-frequency = <162000000>; /* 162MHz */
+               ranges = <0x0c000000 0x0c000000 0x00010000>;

Since you're only doing 1:1 mappings; you could replace this with an
empty "ranges;" property instead.

You could, but being explicit about the supported ranges isn't
bad either.

Hint:  If you move the interrupt-parent property up to the root node,
then you don't need to specify it in every single device node; it will
just inherit from the parent.

If you have only one interrupt controller, like here, you don't
need to refer to it _at all_ :-)


Segher

_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Reply via email to