* Nathan Fontenot <nf...@austin.ibm.com> [2010-10-01 13:35:54]:

> Define a version of memory_block_size_bytes() for powerpc/pseries such that
> a memory block spans an entire lmb.

I hope I am not missing anything obvious, but why not just call it
lmb_size, why do we need memblock_size?

Is lmb_size == memblock_size after your changes true for all
platforms?

> 
> Signed-off-by: Nathan Fontenot <nf...@austin.ibm.com>
> 
> ---
>  arch/powerpc/platforms/pseries/hotplug-memory.c |   66 
> +++++++++++++++++++-----
>  1 file changed, 53 insertions(+), 13 deletions(-)
> 
> Index: linux-next/arch/powerpc/platforms/pseries/hotplug-memory.c
> ===================================================================
> --- linux-next.orig/arch/powerpc/platforms/pseries/hotplug-memory.c   
> 2010-09-30 14:44:37.000000000 -0500
> +++ linux-next/arch/powerpc/platforms/pseries/hotplug-memory.c        
> 2010-09-30 14:47:04.000000000 -0500
> @@ -17,6 +17,54 @@
>  #include <asm/pSeries_reconfig.h>
>  #include <asm/sparsemem.h>
> 
> +static unsigned long get_memblock_size(void)
> +{
> +     struct device_node *np;
> +     unsigned int memblock_size = 0;
> +
> +     np = of_find_node_by_path("/ibm,dynamic-reconfiguration-memory");
> +     if (np) {
> +             const unsigned long *size;
> +
> +             size = of_get_property(np, "ibm,lmb-size", NULL);
> +             memblock_size = size ? *size : 0;
> +
> +             of_node_put(np);
> +     } else {
> +             unsigned int memzero_size = 0;
> +             const unsigned int *regs;
> +
> +             np = of_find_node_by_path("/mem...@0");
> +             if (np) {
> +                     regs = of_get_property(np, "reg", NULL);
> +                     memzero_size = regs ? regs[3] : 0;
> +                     of_node_put(np);
> +             }
> +
> +             if (memzero_size) {
> +                     /* We now know the size of mem...@0, use this to find
> +                      * the first memoryblock and get its size.
> +                      */

Nit: comment style is not correct

> +                     char buf[64];
> +
> +                     sprintf(buf, "/mem...@%x", memzero_size);
> +                     np = of_find_node_by_path(buf);
> +                     if (np) {
> +                             regs = of_get_property(np, "reg", NULL);
> +                             memblock_size = regs ? regs[3] : 0;
> +                             of_node_put(np);
> +                     }
> +             }
> +     }



> +
> +     return memblock_size;
> +}
> +
> +unsigned long memory_block_size_bytes(void)
> +{
> +     return get_memblock_size();
> +}
> +
>  static int pseries_remove_memblock(unsigned long base, unsigned int 
> memblock_size)
>  {
>       unsigned long start, start_pfn;
> @@ -127,30 +175,22 @@
> 
>  static int pseries_drconf_memory(unsigned long *base, unsigned int action)
>  {
> -     struct device_node *np;
> -     const unsigned long *lmb_size;
> +     unsigned long memblock_size;
>       int rc;
> 
> -     np = of_find_node_by_path("/ibm,dynamic-reconfiguration-memory");
> -     if (!np)
> +     memblock_size = get_memblock_size();
> +     if (!memblock_size)
>               return -EINVAL;
> 
> -     lmb_size = of_get_property(np, "ibm,lmb-size", NULL);
> -     if (!lmb_size) {
> -             of_node_put(np);
> -             return -EINVAL;
> -     }
> -
>       if (action == PSERIES_DRCONF_MEM_ADD) {
> -             rc = memblock_add(*base, *lmb_size);
> +             rc = memblock_add(*base, memblock_size);
>               rc = (rc < 0) ? -EINVAL : 0;
>       } else if (action == PSERIES_DRCONF_MEM_REMOVE) {
> -             rc = pseries_remove_memblock(*base, *lmb_size);
> +             rc = pseries_remove_memblock(*base, memblock_size);
>       } else {
>               rc = -EINVAL;
>       }
> 
> -     of_node_put(np);
>       return rc;
>  }
> 
> 
> --
> To unsubscribe, send a message with 'unsubscribe linux-mm' in
> the body to majord...@kvack.org.  For more info on Linux MM,
> see: http://www.linux-mm.org/ .
> Don't email: <a href=mailto:"d...@kvack.org";> em...@kvack.org </a>
> 

-- 
        Three Cheers,
        Balbir
_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Reply via email to