On Thu, Oct 10, 2013 at 09:28:27AM -0700, H. Peter Anvin wrote: > On 10/10/2013 03:17 AM, Alexander Gordeev wrote: > > On Wed, Oct 09, 2013 at 03:24:08PM +1100, Benjamin Herrenschmidt wrote: > > > > Ok, this suggestion sounded in one or another form by several people. > > What about name it pcim_enable_msix_range() and wrap in couple more > > helpers to complete an API: > > > > int pcim_enable_msix_range(pdev, msix_entries, nvec, minvec); > > <0 - error code > > >0 - number of MSIs allocated, where minvec >= result <= nvec > > > > int pcim_enable_msix(pdev, msix_entries, nvec); > > <0 - error code > > >0 - number of MSIs allocated, where 1 >= result <= nvec > > > > int pcim_enable_msix_exact(pdev, msix_entries, nvec); > > <0 - error code > > >0 - number of MSIs allocated, where result == nvec > > > > The latter's return value seems odd, but I can not help to make > > it consistent with the first two. > > > > Is there a reason for the wrappers, as opposed to just specifying either > 1 or nvec as the minimum?
The wrappers are more handy IMO. I.e. can imagine people start struggling to figure out what minvec to provide: 1 or 0? Why 1? Oh.. okay.. Or should we tolerate 0 (as opposite to -ERANGE)? Well, do not know.. pcim_enable_msix(pdev, msix_entries, nvec, nvec) is less readable for me than just pcim_enable_msix_exact(pdev, msix_entries, nvec). > -hpa -- Regards, Alexander Gordeev agord...@redhat.com _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev