aganea marked an inline comment as done. aganea added inline comments.
================ Comment at: llvm/include/llvm/DebugInfo/CodeView/CVRecord.h:29 +/// Carrying the size separately instead of trusting the size stored in the +/// record prefix provides some extra safety and flexibility. template <typename Kind> class CVRecord { ---------------- aganea wrote: > To add to what you said in a comment above, do you think that if we could add > `assert(Data.size() == ((RecordPrefix *)RecordData.data())->RecordPrefix + > 2)` at relevant places below; and then after a while we could simply switch > to `RecordPrefix *`, once issues are ironed out? I didn't mean now. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D60018/new/ https://reviews.llvm.org/D60018 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits