Hui added inline comments.

================
Comment at: 
source/Plugins/Process/Windows/Common/NativeRegisterContextWindows.h:31
+protected:
+  Status ReadAllRegisterValues(lldb::DataBufferSP &data_sp,
+                               const size_t data_size);
----------------
labath wrote:
> Is this overriding something? Can you please use `override` to indicate that 
> (throughout this patch)?
No, it doesn't override anything. It has different signature from  the pure 
virtual method with the same name.


```
NativeRegisterContext::virtual Status ReadAllRegisterValues(lldb::DataBufferSP 
&data_sp) = 0;
```

It would be better to change the name to be ReadAllRegisterValuesWithSize or 
something else.


Repository:
  rLLDB LLDB

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D63165/new/

https://reviews.llvm.org/D63165



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to