aprantl added a comment.

> Yeah, it seems acceptable. The "sdk type" argument still seems somewhat 
> redundant. Theoretically we could pass in just the triple component out the 
> xcodesdk object, but that would just mean the individual platforms would have 
> to reconstruct the XcodeSDK object, which is already present in the caller, 
> so it's not ideal either...

It's an entire string, not just the type, because it also contains an 
(optional) version number.



================
Comment at: lldb/include/lldb/Target/Platform.h:437
 
+  virtual ConstString GetSDKPath(int type) { return {}; }
+
----------------
labath wrote:
> GetXCodeSDKPath? (and maybe the argument can be the proper enum type now.
That would look clean, but unfortunately it has to be a full XcodeSDK string, 
because in addition to the type, it optionally also contains a version number 
and some other bits that are applicable only when developing the OS itself.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D76471/new/

https://reviews.llvm.org/D76471



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to