dblaikie added inline comments.

================
Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFDebugArangeSet.cpp:56
+  if (m_header.length > 0)
+    m_next_offset = m_offset + *offset_ptr - m_offset + m_header.length;
+  else
----------------
clayborg wrote:
> dblaikie wrote:
> > This maths seems strange - the `m_offset ... - m_offset` cancel each other 
> > out, right?
> Math is good. We are adding the number of bytes that were used to encode the 
> length (4 or 12) by saying:
> ```
> m_offset + <length of length encoding> + m_header.length
> ```
The net effect ends up a bit convoluted & I think it'd be (at least I'd find 
it) easier to read as `*offset_ptr + m_header.length`


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D99401/new/

https://reviews.llvm.org/D99401

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to