JDevlieghere marked an inline comment as done.
JDevlieghere added a subscriber: david.
JDevlieghere added a comment.

@David: Yes, I considered it, but I think this is slightly more readable.



================
Comment at: 
lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationClient.cpp:1113
+    std::string packet =
+        "QEnableCompression:type:" + std::string(avail_name) + ";";
+    if (SendPacketAndWaitForResponse(packet, response) != 
PacketResult::Success)
----------------
mgorny wrote:
> I'd personally prefer `avail_name.str()` instead of explicit `std::string()` 
> but that's just me.
Works for me. That actually makes it fit on a single line.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D113314/new/

https://reviews.llvm.org/D113314

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to