clayborg added a comment.

I might suggest we rename things like suggested in my inline comment, and then 
have the "SymbolFile.h" class just include the extra needed header file? Many 
of the changes in this diff would just go away. I am not a fan of the 
SymbolFileActual class nor having to switch to SymbolFileActual.h. I would 
almost prefer both SymbolFileActual and SymbolFile to stay in SymbolFile.h.

I will wait for Pavel to chime in as this was his suggestion.



================
Comment at: lldb/include/lldb/Symbol/SymbolFile.h:45
+/// SymbolFile implementation.
 class SymbolFile : public PluginInterface {
   /// LLVM RTTI support.
----------------
Maybe just rename this to SymbolFileInterface, and then rename 
"SymbolFileActual" to "SymbolFile"?


================
Comment at: lldb/include/lldb/Symbol/SymbolFileActual.h:18
+/// Most actual SymbolFile implementations should inherit from this class.
+class SymbolFileActual : public SymbolFile {
+  /// LLVM RTTI support.
----------------



Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D124110/new/

https://reviews.llvm.org/D124110

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to