mib added inline comments.

================
Comment at: lldb/include/lldb/Host/common/ZipFileResolver.h:30
+
+  static bool ResolveBionicPath(const FileSpec &file_spec, FileKind &file_kind,
+                                std::string &file_path,
----------------
This function name sounds like the the bionic linker is in the zip file which 
is not the case IIUC. I'm fine with adding a zip file resolver in lldb but I'd 
prefer if it had a generic name, otherwise, this should be a plugin.


================
Comment at: lldb/source/Utility/ZipFile.cpp:19-21
+// Zip headers.
+// https://pkware.cachefly.net/webdocs/casestudies/APPNOTE.TXT
+
----------------
Did you just copy & past the this file from somewhere else of did you implement 
it yourself ?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D152759/new/

https://reviews.llvm.org/D152759

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to