bulbazord added inline comments.

================
Comment at: lldb/source/API/SBPlatform.cpp:664-689
+  if (platform_sp) {
+    if (callback) {
+      platform_sp->SetLocateModuleCallback(
+          [callback, callback_baton](const ModuleSpec &module_spec,
+                                     FileSpec &module_file_spec,
+                                     FileSpec &symbol_file_spec) {
+            SBModuleSpec module_spec_sb(module_spec);
----------------
Suggestion: Invert the conditions and use early returns. This function has 
quite a bit of nesting and I think the readability could be improved.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D153735/new/

https://reviews.llvm.org/D153735

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to