Changes in directory llvm/lib/Bytecode/Writer:

Writer.cpp updated: 1.149 -> 1.150
---
Log message:

rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger.
rename Type::getIntegralTypeMask to Type::getIntegerTypeMask.

This makes naming much more consistent.  For example, there are now no longer 
any
instances of IntegerType that are not considered isInteger! :)



---
Diffs of the changes:  (+1 -1)

 Writer.cpp |    2 +-
 1 files changed, 1 insertion(+), 1 deletion(-)


Index: llvm/lib/Bytecode/Writer/Writer.cpp
diff -u llvm/lib/Bytecode/Writer/Writer.cpp:1.149 
llvm/lib/Bytecode/Writer/Writer.cpp:1.150
--- llvm/lib/Bytecode/Writer/Writer.cpp:1.149   Fri Jan 12 18:10:02 2007
+++ llvm/lib/Bytecode/Writer/Writer.cpp Sun Jan 14 20:27:26 2007
@@ -292,7 +292,7 @@
 }
 
 void BytecodeWriter::outputConstant(const Constant *CPV) {
-  assert(((CPV->getType()->isPrimitiveType() || CPV->getType()->isIntegral()) 
||
+  assert(((CPV->getType()->isPrimitiveType() || CPV->getType()->isInteger()) ||
           !CPV->isNullValue()) && "Shouldn't output null constants!");
 
   // We must check for a ConstantExpr before switching by type because



_______________________________________________
llvm-commits mailing list
llvm-commits@cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits

Reply via email to