> >> diff --git a/include/odp/api/cpumask.h b/include/odp/api/cpumask.h
> >> index 7482899..65969c3 100644
> >> --- a/include/odp/api/cpumask.h
> >> +++ b/include/odp/api/cpumask.h
> >> @@ -18,12 +18,20 @@
> >>  extern "C" {
> >>  #endif
> >>
> >> +#include <sys/types.h>
> >> +#include <odp/config.h>
> >> +
> >>  /** @addtogroup odp_scheduler
> >>   *  CPU mask operations.
> >>   *  @{
> >>   */
> >>
> >> - /**
> >> +/**
> >> + * @def ODP_CPUMASK_BUFSIZE
> >> + * Minimum size of output buffer for odp_cpumask_to_str()
> >> + */
> >
> > ODP_CPUMASK_STRLEN is better. Better to use term string when it's a
> character string.

This one is missing from v5.

Better name it STRLEN when it used for _to_str() and _from_str() function calls.

char mask_str[ODP_CPUMASK_STRLEN];
memset(mask_str, 0, sizeof(mask_str));
odp_cpumask_to_str(mask, mask_str, sizeof(mask_str));
odp_cpumask_from_str(mask, mask_str);


-Petri



_______________________________________________
lng-odp mailing list
lng-odp@lists.linaro.org
http://lists.linaro.org/mailman/listinfo/lng-odp

Reply via email to