Merged,
Maxim.

On 07/03/15 15:12, Petri Savolainen wrote:
We have decided to standardize enum naming to typedef _t,
renamed the enum according to that.

Signed-off-by: Petri Savolainen <petri.savolai...@nokia.com>
---
  include/odp/api/packet_io.h | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/include/odp/api/packet_io.h b/include/odp/api/packet_io.h
index 3d42ee0..bc6011e 100644
--- a/include/odp/api/packet_io.h
+++ b/include/odp/api/packet_io.h
@@ -48,14 +48,14 @@ extern "C" {
  /**
   * Packet input mode
   */
-enum odp_pktio_input_mode {
+typedef enum odp_pktio_input_mode_t {
        /** Application polls packet input directly with odp_pktio_recv() */
        ODP_PKTIN_MODE_RECV = 0,
        /** Packet input through scheduled queues */
        ODP_PKTIN_MODE_SCHED,
        /** Application polls packet input queues */
        ODP_PKTIN_MODE_POLL
-};
+} odp_pktio_input_mode_t;
/**
   * Packet IO parameters
@@ -65,7 +65,7 @@ enum odp_pktio_input_mode {
   */
  typedef struct odp_pktio_param_t {
        /** Packet input mode */
-       enum odp_pktio_input_mode in_mode;
+       odp_pktio_input_mode_t in_mode;
  } odp_pktio_param_t;
/**

_______________________________________________
lng-odp mailing list
lng-odp@lists.linaro.org
https://lists.linaro.org/mailman/listinfo/lng-odp

Reply via email to