v7:  - fix classiefier unit tests
     - split add ODP_PMR_CUSTOM_FRAME in 2
       - One patch changes odp_pmr_create signature to use a struct instead of 
arg list
       - Second one only adds ODP_PMR_CUSTOM_FRAME to the api

v6:  - rebase on latest api-next

v5:  - change linux-generic pmr_term_value_t fields offset and
       val_sz from uint16_t to uint32_t to match API types

v4:  - move definitions prior to any API modifiction to improve
       readability
     - change comment so that odp_pmr_match_t.offset is ignored
       if not used instead of enforcing a 0 value

v3:  - split the api patch in two: 1st one to modify api, 2nd one
       to move declarations for readability

v2:  - rename ODP_PMR_OFFSET_ABS to ODP_PMR_CUSTOM_FRAME
     - better doc (including the fact that ODP_PMR_CUSTOM_FRAME
       should be applied before other PMR)
     - reuse odp_pmr_match_t for both single PMR and PMR sets
       creation

BenoƮt Ganne (3):
  api: classification: move odp_pmr_match_t definition
  linux-generic: classification: implement ODP_PMR_CUSTOM_FRAME matching
  example: classifier: implement ODP_PMR_CUSTOM_FRAME match

Nicolas Morey-Chaisemartin (2):
  api: classification: use a structure instead of many args for
    odp_pmr_create
  api: classification: add ODP_PMR_CUSTOM_FRAME

 example/classifier/odp_classifier.c                | 96 +++++++++++++++++-----
 include/odp/api/classification.h                   | 55 ++++++-------
 .../include/odp_classification_datamodel.h         |  2 +
 .../include/odp_classification_inlines.h           | 21 +++++
 platform/linux-generic/odp_classification.c        | 42 +++++-----
 .../classification/odp_classification_basic.c      | 18 +++-
 .../classification/odp_classification_tests.c      | 28 +++++--
 7 files changed, 186 insertions(+), 76 deletions(-)

_______________________________________________
lng-odp mailing list
lng-odp@lists.linaro.org
https://lists.linaro.org/mailman/listinfo/lng-odp

Reply via email to