In general I like this restructure.  I'll add this to the topics for the
ARCH call on the 4th.  Some general comments:

   1. Renaming SCHED_SYNC_NONE to SCHED_SYNC_PARALLEL is good as we talk
   about Parallel, Atomic, and Ordered queues so this is reducing confusion.
   2. If we're introducing a SINK queue type I'm wondering if this
   shouldn't be mirrored by a SOURCE queue type?  Or would it be clearer if we
   somehow added RX and TX to these names to reflect their roles in Packet I/O?
   3. The Pktin/Pktout mode changes seem somewhat awkward.
   ODP_PKTIN_MODE_xxx_QUEUE seems a bit of a mouthful. Perhaps
   ODP_PKTIN_MODE_QUEUE and ODP_PKTIN_MODE_SCHED would be simpler for these
   two?


On Tue, Dec 29, 2015 at 7:33 AM, Petri Savolainen <
petri.savolai...@nokia.com> wrote:

> I'm proposing these renames before Monarch release. Scheduled "none queues"
> and directly accessed "poll queues" are not optimal terms to rescribe how
> those
> queue types are used. "Parallel" and "direct" queues offer better terms.
> PKTIN
> queue type will be removed. PKTOUT type should be replaced with SINK,
> which is
> more generic type for any kind of sink interface (application cannot
> dequeue
> from it).
>
> PKTIO modes are aligned with DIRECT, SCHED and SINK queue types.
>
>
> Petri Savolainen (5):
>   api: sched: rename SCHED_SYNC_NONE to _PARALLEL
>   api: queue: rename QUEUE_TYPE_POLL to _DIRECT
>   api: pktio: rename pktin and pktout modes
>   api: queue: added QUEUE_TYPE_SINK
>   api: pktio: added PKTOUT_MODE_SINK_QUEUE
>
>  example/classifier/odp_classifier.c                |  6 +-
>  example/generator/odp_generator.c                  |  8 +-
>  example/ipsec/odp_ipsec.c                          | 10 +--
>  example/packet/odp_pktio.c                         |  6 +-
>  example/timer/odp_timer_test.c                     |  2 +-
>  include/odp/api/packet_io.h                        | 16 ++--
>  include/odp/api/queue.h                            | 11 ++-
>  include/odp/api/schedule_types.h                   | 12 +--
>  .../linux-generic/include/odp/plat/queue_types.h   |  9 ++-
>  .../include/odp/plat/schedule_types.h              |  2 +-
>  platform/linux-generic/odp_packet_io.c             | 20 ++---
>  platform/linux-generic/odp_schedule.c              |  4 +-
>  platform/linux-generic/pktio/loop.c                |  2 +-
>  platform/linux-generic/pktio/netmap.c              | 16 ++--
>  test/performance/odp_l2fwd.c                       | 20 ++---
>  test/performance/odp_pktio_perf.c                  |  8 +-
>  test/performance/odp_scheduling.c                  |  2 +-
>  .../classification/odp_classification_common.c     |  4 +-
>  .../classification/odp_classification_test_pmr.c   | 12 +--
>  .../classification/odp_classification_tests.c      | 16 ++--
>  test/validation/crypto/crypto.c                    |  2 +-
>  test/validation/pktio/pktio.c                      | 86
> +++++++++++-----------
>  test/validation/queue/queue.c                      | 13 ++--
>  test/validation/scheduler/scheduler.c              | 45 +++++------
>  test/validation/timer/timer.c                      |  4 +-
>  25 files changed, 178 insertions(+), 158 deletions(-)
>
> --
> 2.6.3
>
> _______________________________________________
> lng-odp mailing list
> lng-odp@lists.linaro.org
> https://lists.linaro.org/mailman/listinfo/lng-odp
>
_______________________________________________
lng-odp mailing list
lng-odp@lists.linaro.org
https://lists.linaro.org/mailman/listinfo/lng-odp

Reply via email to