On 2 August 2016 at 17:27, Mike Holmes <mike.hol...@linaro.org> wrote:
> On 2 August 2016 at 04:44, Maxim Uvarov <maxim.uva...@linaro.org> wrote:
>
>> On 08/02/16 10:54, Anders Roxell wrote:
>>
>>> Signed-off-by: Anders Roxell <anders.rox...@linaro.org>
>>> ---
>>>   helper/hashtable.c | 6 +++---
>>>   1 file changed, 3 insertions(+), 3 deletions(-)
>>>
>>> diff --git a/helper/hashtable.c b/helper/hashtable.c
>>> index 8bb1ae5..f17b80f 100644
>>> --- a/helper/hashtable.c
>>> +++ b/helper/hashtable.c
>>> @@ -164,7 +164,7 @@ odph_table_t odph_hash_table_lookup(const char *name)
>>>    * This hash algorithm is the most simple one, so we choose it as an
>>> DEMO
>>>    * User can use any other algorithm, like CRC...
>>>    */
>>> -uint16_t odp_key_hash(void *key, uint32_t key_size)
>>> +static uint16_t odp_key_hash(void *key, uint32_t key_size)
>>>
>> odph_
>>
>>>   {
>>>         register uint32_t hash = 0;
>>>         uint32_t idx = (key_size == 0 ? 1 : key_size);
>>> @@ -181,7 +181,7 @@ uint16_t odp_key_hash(void *key, uint32_t key_size)
>>>   /**
>>>    * Get an available node from pool
>>>    */
>>> -odph_hash_node *odp_hashnode_take(odph_table_t table)
>>> +static odph_hash_node *odp_hashnode_take(odph_table_t table)
>>>   {
>>>         odph_hash_table_imp *tbl = (odph_hash_table_imp *)table;
>>>         uint32_t idx;
>>> @@ -208,7 +208,7 @@ odph_hash_node *odp_hashnode_take(odph_table_t table)
>>>   /**
>>>    * Release an node to the pool
>>>    */
>>> -void odp_hashnode_give(odph_table_t table, odph_hash_node *node)
>>> +static void odp_hashnode_give(odph_table_t table, odph_hash_node *node)
>>>
>>>
>> odph_
>
>
> Should this patch change the name as well ?

I would say no. =)

> The fix appears to be to correctly make internal functions static whist
> converting to a naming scheme is a separate fix

agree.

Cheers,
Anders

>
>
>>
>> {
>>>         odph_hash_table_imp *tbl = (odph_hash_table_imp *)table;
>>>
>>>
>>
>>
>
>
> --
> Mike Holmes
> Technical Manager - Linaro Networking Group
> Linaro.org <http://www.linaro.org/> *│ *Open source software for ARM SoCs
> "Work should be fun and collaborative, the rest follows"

Reply via email to