I see:
org.apache.logging.log4j.core.filter.CompositeFilter.createFilters(Filter[]):
@PluginFactory
public static CompositeFilter createFilters(@PluginElement("Filters")
final Filter[] filters) {
Which is clear, but then I see:
public static FileAppender createAppender(
// @formatter:off
...
@PluginElement("Filters") final Filter filter,
...
So it seems like one filter elements (not arrays) should be renamed from
"Filters" to "Filter".
That or the discrepancy between the plural name and singular element needs
to be in the Javadoc.
Thoughts?
--
E-Mail: [email protected] | [email protected]
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory