[ 
https://issues.apache.org/jira/browse/LOG4J2-1807?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15874266#comment-15874266
 ] 

Mikael Ståldal commented on LOG4J2-1807:
----------------------------------------

Given that we are not very happy with this, I think we should avoid exposing 
new public methods, so that we don't tie us further into a suboptimal design.

The first one (one-arg) is new and not released yet, so we can change it if we 
want to.

First, the new non-static {{Log4jLogEvent.createMemento}} can be removed since 
it is not used anywhere. Then, the new static one-arg 
{{Log4jLogEvent.createMemento}} can be renamed to something else.

What do we need to maintain binary compatibility in the 
{{org.apache.logging.log4j.core.impl}} package?


> [core] Add and implement LogEvent.toImmutable()
> -----------------------------------------------
>
>                 Key: LOG4J2-1807
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-1807
>             Project: Log4j 2
>          Issue Type: New Feature
>    Affects Versions: 2.8.1
>            Reporter: Gary Gregory
>            Assignee: Gary Gregory
>         Attachments: logging-log4j2.patch
>
>
> [core] Add and implement LogEvent.asImmutable()
> {code:java}
>     /**
>      * Returns an immutable version of this log event, which MAY BE a copy of 
> this event.
>      *  
>      * @return an immutable version of this log event
>      */
>     LogEvent asImmutable();
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscr...@logging.apache.org
For additional commands, e-mail: log4j-dev-h...@logging.apache.org

Reply via email to