hi all,

Daniel did a great job when cleaning up the Field class to make it more readable for the user. Wouldn't it be the best time to clean up the 3 IndexReader methods which are directly related to field names ? Currently there are 3 different methods available to get the field names from an index.

a) getFieldNames();
b) getFieldNames(boolean indexed);
c) getIndexedFieldNames(boolean storedTermVector);

my proposal is to deprecate a), b) and c) and add one new method which can handle all the possible options. The implementation could be similar to the new Store, Index etc. implementation in Field class. Adding a public static final class to IndexReader like:

public static final class FieldNames {
private String option;
private FieldNames() {}
private FieldNames(String option) {
this.option = option;
}
public String toString() {
return option;
}
public static final FieldNames ALL = new FieldNames ("ALL");
public static final FieldNames INDEXED = new FieldNames ("INDEXED");
....
}


we would end up with a method like:

getFieldNames(FieldNames names);

any thoughts on it ?

Bernhard


--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to