On Wed, Jun 13, 2001 at 08:54:40AM +0200, Lars Gullik Bjønnes wrote:

> 
> I disagree with this change... I really thing we should make it a rule
> to always use  { ... } instead. Why?
>         - consistency
>         - people will not be tempted to drop the {...} after comples
>           conditionals
>         - somewhat easier to follow program flow.
> 
> 
> -             else if (c == META_INSET) {
> +             else if (c == META_INSET)
>                       GetInset(i)->Ascii(buffer, ost);
> -             }
>       }

on the other side of things, the always-brace rule has the disadvantage of an
extra line of vertical screen space.

However, I am happy to go with whatever you care to write in the coding style
document (you /are/ going to patch this right ?)

thanks
john

-- 
"They're talking about a submanifold of space which is a 2-dimensional torus whose 
cross-sectional radii 
 are on the order of a millimeter.  Please make some minimal attempt to understand 
what's being 
 discussed before declaring it 'drivel'."
        - AC, /.

Reply via email to