Andre Poenitz <[EMAIL PROTECTED]> writes:

| >         ParagraphList::const_iterator it =
| >                 find_if(pars_.begin(), pars_.end(), some_functor(par));
| 
| Why? It's obviously more code to type, to read, and not simpler to
| understand. You obviously could write out the for loop but cut the
| corner in the some_functor case.

?? I cannot grok that last sentence.
 
| [Thing would obviously different with lambda...]
| 
| > | Of course, profiling would be interesting too :)
| > 
| > Clearity wins.
| 
| IMO the for loop is much clearer...

break it out into a function name "find" then.

It is the "find" that makes it clear.... we have (and have had) too
many manual loops... only by close inspection is it clear if this is a
disguised find, a count something else.

-- 
        Lgb

Reply via email to