[
https://issues.apache.org/jira/browse/MAHOUT-354?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12851900#action_12851900
]
Hui Wen Han commented on MAHOUT-354:
------------------------------------
I try it again
> make the output of RecommenderJob more readable
> -----------------------------------------------
>
> Key: MAHOUT-354
> URL: https://issues.apache.org/jira/browse/MAHOUT-354
> Project: Mahout
> Issue Type: Improvement
> Components: Collaborative Filtering
> Affects Versions: 0.4
> Reporter: Hui Wen Han
> Attachments: screenshot-1.jpg
>
>
> now the output of RecommenderMapper as following:
> output.collect(userID, new RecommendedItemsWritable(recommendations));
> Can we change it more readable like following:
> private final Text user = new Text();
> private final Text recomScore = new Text();
> private static final String FIELD_SEPERATOR = ",";
> for (RecommendedItem recommendation : recommendations)
> {
> user.set(String.valueOf(userId));
> recomScore.set(recommendation.getItemID() + FIELD_SEPERATOR +
> recommendation.getValue());
> output.collect(user, recomScore);
> }
> then user can read and verify the result more convenient and need not depend
> on the mahout API
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.