[
https://issues.apache.org/jira/browse/MAPREDUCE-1408?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
rahul k singh updated MAPREDUCE-1408:
-------------------------------------
Attachment: 1408-4.patch
added some offline comments by chris:
{{JobFactory::FilterJobStory}} should remain a static class
{{JobFactory::createReaderThread}} should be abstract, rather than returning an
instance of {{Thread}}
Initializing the polling interval as a final param- as the name is- in
{{GridmixJobSubmissionPolicy}} would be more canonical
> Allow customization of job submission policies
> ----------------------------------------------
>
> Key: MAPREDUCE-1408
> URL: https://issues.apache.org/jira/browse/MAPREDUCE-1408
> Project: Hadoop Map/Reduce
> Issue Type: Bug
> Components: contrib/gridmix
> Reporter: rahul k singh
> Attachments: 1408-1.patch, 1408-2.patch, 1408-2.patch,
> 1408-20-2.patch, 1408-20-3.patch, 1408-20.patch, 1408-3.patch, 1408-4.patch
>
>
> Currently, gridmix3 replay job submission faithfully. For evaluation
> purposes, it would be great if we can support other job submission policies
> such as sequential job submission, or stress job submission.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.