[ 
https://issues.apache.org/jira/browse/MAPREDUCE-1912?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12888300#action_12888300
 ] 

Ravi Gummadi commented on MAPREDUCE-1912:
-----------------------------------------

Some comments:

(1) In build.xml, please change ${common.ivy.lib.dir dir} to 
${common.ivy.lib.dir} directory.

(2) In Folder.java, in initialize() method, printUsage() should be called at 
the 2 places where IllegalArgumentException is thrown(just before throwing).

(3) In Rumen.java, please change "A Rumen tool fold/scale the trace" to "A 
Rumen tool to fold/scale the trace".

(4) In TraceBuilder.java, please reverse the conditions in the following while 
statement so that validation of index is done before accessing the element at 
that index. {code}while (args[switchTop].startsWith("-") && switchTop < 
args.length){code}

(5) As you observed the bug, please make the necessary code change of moving 
"++switchTop;" out of if statement in the above while loop --- to fix the bug 
of the infinite loop when some option that starts with "-"(and is not same as 
-denuxer) is given.

(6) In both places in TraceBuilder.java where printUsage() is called, you are 
checking the case of zero more arguments only. We need to make sure that there
are at least 3 arguments in both places.
So change (a) "if (0 == args.length)" to "if (args.length < 3)" and (b) "if 
(switchTop == args.length)" to "if (switchTop+2 >= args.length)".

> [Rumen] Add a driver for Rumen tool 
> ------------------------------------
>
>                 Key: MAPREDUCE-1912
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1912
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: tools/rumen
>    Affects Versions: 0.22.0
>            Reporter: Amar Kamat
>            Assignee: Amar Kamat
>             Fix For: 0.22.0
>
>         Attachments: mapreduce-1912-v1.1.patch
>
>
> Rumen, as a tool, has 2 entry points :
> - Trace builder
> - Folder
> It would be nice to have a single driver program and have 'trace-builder' and 
> 'folder' as its options. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to