[ https://issues.apache.org/jira/browse/MAPREDUCE-6579?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15121298#comment-15121298 ]
Akira AJISAKA commented on MAPREDUCE-6579: ------------------------------------------ bq. Do you think we should rename JobStatus#getFailureInfo? Diagnostic message doesn't always means failure, JobStatus's InterfaceStability marked to "Evolving", we can update it. I don't think we should rename {{JobStatus#getFailureInfo}} because Apache Tez is overriding this method. https://github.com/apache/tez/blob/master/tez-mapreduce/src/main/java/org/apache/tez/mapreduce/client/DAGJobStatus.java {code} @Override public synchronized String getFailureInfo() { return Joiner.on(". ").join(dagStatus.getDiagnostics()); } {code} Insteadly, we can deprecate the method in trunk/branch-2 and remove it in trunk. I'm thinking it should be done in a separate jira. bq. I would suggest not compare the diagnostic info, it is evolving, only human is supposed to read this message and we have test in YARN already. Agree. I'll remove the assertion. > Test failure : TestNetworkedJob > ------------------------------- > > Key: MAPREDUCE-6579 > URL: https://issues.apache.org/jira/browse/MAPREDUCE-6579 > Project: Hadoop Map/Reduce > Issue Type: Bug > Components: test > Reporter: Rohith Sharma K S > Assignee: Akira AJISAKA > Attachments: MAPREDUCE-6579.01.patch, MAPREDUCE-6579.02.patch, > MAPREDUCE-6579.03.patch > > > From > [https://builds.apache.org/job/PreCommit-YARN-Build/9976/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_66.txt] > TestNetworkedJob are failed intermittently. > {code} > Running org.apache.hadoop.mapred.TestNetworkedJob > Tests run: 5, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 81.131 sec > <<< FAILURE! - in org.apache.hadoop.mapred.TestNetworkedJob > testNetworkedJob(org.apache.hadoop.mapred.TestNetworkedJob) Time elapsed: > 30.55 sec <<< FAILURE! > org.junit.ComparisonFailure: expected:<[[Tue Dec 15 14:02:45 +0000 2015] > Application is Activated, waiting for resources to be assigned for AM. > Details : AM Partition = <DEFAULT_PARTITION> ; Partition Resource = > <memory:8192, vCores:16> ; Queue's Absolute capacity = 100.0 % ; Queue's > Absolute used capacity = 0.0 % ; Queue's Absolute max capacity = 100.0 % ; ]> > but was:<[]> > at org.junit.Assert.assertEquals(Assert.java:115) > at org.junit.Assert.assertEquals(Assert.java:144) > at > org.apache.hadoop.mapred.TestNetworkedJob.testNetworkedJob(TestNetworkedJob.java:174) > {code} -- This message was sent by Atlassian JIRA (v6.3.4#6332)