-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123304/#review78712
-----------------------------------------------------------



src/lib/marble/geodata/scene/GeoSceneTextureTile.h (line 36)
<https://git.reviewboard.kde.org/r/123304/#comment53859>

    Are there any reasons not to call this:
    
    setLatLonBox(GeoDataLatLonBox &box)
    
    for reasons of naming consistency?
    
    I guess we should pick GeoDataLatLonBox over GeoDataLatLonAltBox since the 
latter inherits from the former but since we don't take the altitude into 
account for rendering - or are there chances that we ever will? and might it be 
possible that we get hard to track bugs if we allow for specifying the altitude 
range while not properly evaluating it?)



src/lib/marble/geodata/scene/GeoSceneTextureTile.h (line 37)
<https://git.reviewboard.kde.org/r/123304/#comment53860>

    GeoDataLatLonBox latLonBox() const



src/lib/marble/geodata/scene/GeoSceneTextureTile.h (line 40)
<https://git.reviewboard.kde.org/r/123304/#comment53861>

    m_latLonBox


- Torsten Rahn


On April 9, 2015, 9:22 vorm., Adam Dabrowski wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123304/
> -----------------------------------------------------------
> 
> (Updated April 9, 2015, 9:22 vorm.)
> 
> 
> Review request for Marble.
> 
> 
> Repository: marble
> 
> 
> Description
> -------
> 
> Before this patch, there is an assumption that every texture layer spans the 
> whole globe. Tiles are searched on all previous levels in TileLoader for each 
> geo texture, while it can be the case that the texture layer only spans in 
> certain area (like aerial photos of a certain city). It is both ineffective 
> and unnecessary.
> 
> The patch allows for textures that are bounded by a specified latlon box. 
> With these patch, bounding box can be set for dynamic textures. Additional 
> support and coding for dgml tags parsing should follow.
> 
> 
> Diffs
> -----
> 
>   src/lib/marble/MergedLayerDecorator.cpp d4652e4 
>   src/lib/marble/geodata/scene/GeoSceneTextureTile.h 5c53779 
>   src/lib/marble/geodata/scene/GeoSceneTextureTile.cpp 6662368 
> 
> Diff: https://git.reviewboard.kde.org/r/123304/diff/
> 
> 
> Testing
> -------
> 
> Displayed a bounded texture, tested for backwards compability.
> 
> 
> Thanks,
> 
> Adam Dabrowski
> 
>

_______________________________________________
Marble-devel mailing list
Marble-devel@kde.org
https://mail.kde.org/mailman/listinfo/marble-devel

Reply via email to