Hello!

I want to change 2 smbfs features:

o I need to see dot files. There is a comment in loaddir_helper about ~$ 
  files. Such files really screws mc, and it is must be fixed.

o Now mc stores incorrectly typed password and don't ask for it then
  this share/username is accessed again, so there is no way to retype it.
  It is not nice to restart mc after such errors.

If someone does not agree, let me know.

Regards,
Andrew.

--- ChangeLog.orig      Mon May 21 13:18:12 2001
+++ ChangeLog   Mon May 21 20:15:56 2001
@@ -1,3 +1,12 @@
+2001-05-21  Andrew V. Samoilov  <[EMAIL PROTECTED]>
+
+       * smbfs.c: Include background.h
+       (is_error): commented
+       (loaddir_helper): don't ignore hidden files
+       (do_connect): cli_shutdown () and authinfo_remove () called if
+         cli_session_setup () fails. It is not good idea to remember
+         wrong username/password.
+
 2001-05-18  Pavel Roskin  <[EMAIL PROTECTED]>
 
        * vfs.c (vfs_addstamp): Rename st1 to last_stamp. Initialize it
Index: smbfs.c
===================================================================
RCS file: /home/sav/.cvsroot/mc/vfs/smbfs.c,v
retrieving revision 1.18
diff -u -p -r1.18 smbfs.c
--- smbfs.c     2001/04/09 12:18:28     1.18
+++ smbfs.c     2001/05/21 16:05:51
@@ -48,6 +48,7 @@
 #include "../src/widget.h"
 #include "../src/color.h"
 #include "../src/wtools.h"
+#include "../src/background.h" /* message_* family */
 
 #define SMBFS_MAX_CONNECTIONS 16
 char *IPC = "IPC$";
@@ -554,10 +555,10 @@ loaddir_helper(file_info *finfo, const c
 {
        dir_entry *new_entry;
        time_t t = finfo->mtime; /* the time is assumed to be passed as GMT */
-
+#if 0  /* I want to see dot files */
        if (finfo->mode & aHIDDEN)
                return; /* dont bother with hidden files, "~$" screws up mc */
-
+#endif
        new_entry = g_new (dir_entry, 1);
     new_entry->text = dos_to_unix (g_strdup(finfo->name), 1);
 
@@ -1311,6 +1308,7 @@ smbfs_get_path(smbfs_connection **sc, ch
        return remote_path;
 }
 
+#if 0
 static int
 is_error (int result, int errno_num)
 {
@@ -1320,6 +1318,7 @@ is_error (int result, int errno_num)
                my_errno = errno_num;
     return 1;
 }
+#endif
 
 static void *
 smbfs_opendir (vfs *me, char *dirname)

_______________________________________________
Mc-devel mailing list
[EMAIL PROTECTED]
http://mail.gnome.org/mailman/listinfo/mc-devel

Reply via email to