Ori.livneh has uploaded a new change for review.

Change subject: Re-factor: add RemoteSchema class, require revision
......................................................................

Re-factor: add RemoteSchema class, require revision

Requiring a revision ID dramatically simplfies the work done by this
extension, and it prompted me to do a pretty comprehensive refactor.

-- Remove SchemaModuleTest.php. I'll have to completely rewrite those
   tests. Saving that for another change.
-- Require revision ID for all schema modules.
-- Change modification time behavior accordingly (explained in
   comments).
-- Drop PageContentSave hook handler from JsonSchemaHooks (revisions are
   immutable and don't need to be updated.)
-- Parcel off schema fetching logic to RemoteSchema class.
-- Drop wfSchemaKey function (no longer needed).
-- Rename wfLogServerSideEvent to efLogServerSideEvent, following
   conventions on global funcs declared in extensions.
-- i18nize invalid JSON error message.

Change-Id: I081f98978ca85fefe85a5e746160895a8951c73f
---
M EventLogging.hooks.php
M EventLogging.i18n.php
M EventLogging.module.php
M EventLogging.php
A RemoteSchema.php
M content/JsonSchemaContent.php
M content/JsonSchemaHooks.php
D tests/SchemaModuleTest.php
8 files changed, 156 insertions(+), 328 deletions(-)


  git pull ssh://gerrit.wikimedia.org:29418/mediawiki/extensions/EventLogging 
refs/changes/57/37657/1
--
To view, visit https://gerrit.wikimedia.org/r/37657
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I081f98978ca85fefe85a5e746160895a8951c73f
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/extensions/EventLogging
Gerrit-Branch: master
Gerrit-Owner: Ori.livneh <o...@wikimedia.org>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to